Mautic 2.13.0: Novas funcionalidades e excelentes recursos

Mautic 2.13.0 resolve mais de 60 issues e é um dos maiores lançamentos dos últimos meses corrigindo mais de 60 pequenos erros e incrementando recursos existentes. A Plataforma Mautic cresce a cada dia!

A Equipe de desenvolvimento do Mautic continua com o ritmo de um update da ferramenta numa janela entre 30 / 40 dias. Com o lançamento previsto para o dia 04 de Abril de 2018 o Mautic 2.13.0 chega recheado de correções e boas novidades. Vamos lá?

Sobre o Mautic 2.13.0

Este artigo contém os itens que já estão testados e mesclados na versão de testes do Mautic 2.13.0. Novos recursos podem entrar a qualquer momento … fique ligado 😉

Mautic 2.13.0 adiciona parâmetros ao comando mautic:broadcasts:send

O Comando mautic:broadcasts:send é responsável por enviar os e-mails de segmento e não possui nenhum parâmetro para otimização do processamento da fila. O Mautic 2.13.0 permitirá utilizar novos parâmetros como –limit, –batch, –min-contact-id e –max-contact-id. Estes dois últimos são excelentes novidades pois permite rodar em paralelo listas com milhões de contatos separados por um intervalo de ID’s. Veja a lista completa dos comandos no nosso Guia Definitivo de Crons do Mautic.


Pull #5715

Agora podemos clonar segmentos

Aqui na Powertic recomendados aos clientes para segmentar a base de contatos com “micro segmentos” e muitas vezes este trabalho é penoso já que a maioria dos parâmetros de filtro são iguais. Agora será possível clonar segmentos e assim ganhar muito tempo na segmentação da base de contatos.




Pull #5644

Mautic 2.13.0 permite utilizar mais provedores de SMS

Uma mudança no código do Mautic permitirá incluir novos provedores de SMS de uma modo mais simples e isso é ótimo pois não nos prende mais ao Twilio. Com esse novo Gateway será possível integrar praticamente qualquer provedor de SMS que tenha uma API disponível e sua equipe de desenvolvimento poderá criar novas regras de envio. Uma excelente novidade para quem usa o Mautic em Múltiplos Canais.


Pull 5854

Correções nas crons de campanhas

Um erro que costuma atrapalhar muito campanhas com grandes volumes de leads onde uma falha no envio de e-mails ou no processamento dos gatilhos impede o andamento da execução das campanhas e retorna o seguinte erro:

[DoctrineORMEntityNotFoundException]
 Entity of type 'MauticCampaignBundleEntityLeadEventLog' for IDs id(4863) was not found

O Mautic 2.13.0 inclui novos tratamentos para exceções e corrige este e diversos outros problemas na execução de campanhas.


Pull #3929

Novo Plugin: Zapier

Este plugin é uma lista das integrações  mais populares do Mautic com o Zapier.

Mautic Zapier

Veja nosso artigo completo sobre a integração entre Mautic e Zapier.

Melhorias na API do Mautic 2.13.0

A API do Mautic 2.13.0 melhorias muito bem vindas que aplicam melhores práticas para consistência de dados e também novos recursos interessantes para equipes de desenvolvimento. Veja:

  • Envio de SMS através da API;
  • Melhorias na mesclagem de contatos através da API;
  • Validação de nomes existentes para a criação de novos campos pela API;
  • Correção dos parâmetros de Datas nas Atividades do Contato da API;

Melhorias na visualização de Ações de Campanhas

As ações de campanhas que enviam e-mail agora existem a porcentagem total de ações executadas (verde), o número de ações que foram realmente executadas (amarelo) e as ações que estão pendentes ou foram agendadas para o futuro (cinza).

Assim fica muito mais fácil visualizar quantos e-mails foram realmente enviados e quantos fora agendados 😉

Correções e melhorias no Login Social do Mautic

O Mautic 2.13.0 recria a implementação do Login Social corrigindo uma série de funcionalidades.

Bibliotecas do Framework Atualizadas

De tempos em tempos a equipe de desenvolvimento atualiza as bibliotecas que compõem o Mautic. Estas atualizações são importantes pois auxiliam na estabilidade da ferramenta pois muitos bugs são corrigidos além melhorias de desempenho. Veja abaixo a lista completa de atualizações:

 - Removing stecman/symfony-console-completion (0.7.0)
  - Updating symfony/debug (v2.8.28 => v2.8.34)
  - Updating symfony/property-access (v2.8.28 => v2.8.34)
  - Updating symfony/polyfill-mbstring (v1.6.0 => v1.7.0)
  - Updating symfony/options-resolver (v2.8.28 => v2.8.34)
  - Updating symfony/polyfill-php54 (v1.6.0 => v1.7.0)
  - Updating symfony/polyfill-intl-icu (v1.6.0 => v1.7.0)
  - Updating symfony/intl (v2.8.28 => v2.8.34)
  - Updating symfony/event-dispatcher (v2.8.28 => v2.8.34)
  - Updating symfony/form (v2.8.28 => v2.8.34)
  - Updating symfony/validator (v2.8.28 => v2.8.34)
  - Updating symfony/polyfill-apcu (v1.6.0 => v1.7.0)
  - Updating symfony/cache (v3.3.10 => v3.4.4)
  - Updating symfony/class-loader (v2.8.28 => v2.8.34)
  - Updating symfony/polyfill-util (v1.6.0 => v1.7.0)
  - Updating symfony/polyfill-php70 (v1.6.0 => v1.7.0)
  - Updating symfony/polyfill-php56 (v1.6.0 => v1.7.0)
  - Updating symfony/polyfill-php55 (v1.6.0 => v1.7.0)
  - Updating symfony/security (v2.8.28 => v2.8.34)
  - Updating symfony/http-foundation (v2.8.28 => v2.8.34)
  - Updating symfony/http-kernel (v2.8.28 => v2.8.34)
  - Updating symfony/security-bundle (v2.8.28 => v2.8.34)
  - Updating symfony/monolog-bridge (v2.8.28 => v2.8.34)
  - Updating symfony/asset (v2.8.28 => v2.8.34)
  - Updating symfony/twig-bundle (v2.8.28 => v2.8.34)
  - Updating symfony/console (v2.8.28 => v2.8.34)
  - Updating doctrine/orm (v2.5.12 => v2.5.14)
  - Updating symfony/doctrine-bridge (v2.8.28 => v2.8.34)
  - Updating symfony/dependency-injection (v2.8.28 => v2.8.34)
  - Updating symfony/templating (v2.8.28 => v2.8.34)
  - Updating symfony/stopwatch (v2.8.28 => v2.8.34)
  - Updating symfony/routing (v2.8.28 => v2.8.34)
  - Updating symfony/finder (v2.8.28 => v2.8.34)
  - Updating symfony/filesystem (v2.8.28 => v2.8.34)
  - Updating symfony/config (v2.8.28 => v2.8.34)
  - Updating symfony/framework-bundle (v2.8.28 => v2.8.34)
  - Updating doctrine/doctrine-bundle (1.6.13 => 1.8.1)
  - Updating knplabs/knp-menu (2.2.0 => 2.3.0)
  - Updating knplabs/knp-menu-bundle (2.1.3 => v2.2.1)
  - Updating oneup/uploader-bundle (1.8.3 => 1.9.2)
  - Updating composer/ca-bundle (1.0.8 => 1.1.0)
  - Updating maxmind/web-service-common (v0.4.0 => v0.5.0)
  - Updating geoip2/geoip2 (v2.7.0 => v2.8.0)
  - Updating giggsey/locale (1.3 => 1.4)
  - Updating giggsey/libphonenumber-for-php (8.8.4 => 8.8.11)
  - Updating misd/phone-number-bundle (v1.2.0 => v1.3.2)
  - Updating twilio/sdk (4.12.0 => 4.12.1)
  - Updating stack/builder (v1.0.4 => v1.0.5)
  - Updating sonata-project/exporter (1.7.1 => 1.8.0)
  - Updating symfony/expression-language (v2.8.28 => v2.8.34)
  - Updating symfony/dotenv (v3.3.10 => v3.4.4)
  - Updating symfony/yaml (v2.8.28 => v2.8.34)
  - Updating php-amqplib/php-amqplib (v2.7.0 => v2.7.2)
  - Updating php-amqplib/rabbitmq-bundle (v1.13.0 => v1.14.2)
  - Updating leezy/pheanstalk-bundle (3.2.1 => 3.2.3)
  - Updating simshaun/recurr (v3.0.2 => v3.0.5)
  - Updating ramsey/uuid (3.7.1 => 3.7.3)
  - Updating symfony/web-profiler-bundle (v2.8.28 => v2.8.34)
  - Updating symfony/dom-crawler (v2.8.28 => v2.8.34)
  - Updating symfony/browser-kit (v2.8.28 => v2.8.34)
  - Updating liip/functional-test-bundle (1.8.0 => 1.9.3)
  - Updating symfony/process (v2.8.28 => v2.8.34)
  - Updating sensio/generator-bundle (v3.1.6 => v3.1.7)
  - Updating symfony/polyfill-php72 (v1.6.0 => v1.7.0)
  - Updating gecko-packages/gecko-php-unit (v2.2 => v2.2.1)
  - Updating friendsofphp/php-cs-fixer (v2.2.8 => v2.2.16)
  - Updating symfony/var-dumper (v3.3.10 => v3.4.4)
  - Updating symfony/css-selector (v3.3.10 => v3.4.4)
  - Updating phpunit/php-file-iterator (1.4.2 => 1.4.5)
  - Updating phpunit/php-token-stream (1.4.11 => 1.4.12)
  - Updating webmozart/assert (1.2.0 => 1.3.0)
  - Updating phpdocumentor/type-resolver (0.3.0 => 0.4.0)
  - Updating phpdocumentor/reflection-docblock (3.2.2 => 3.3.2)
  - Updating phpspec/prophecy (v1.7.2 => 1.7.4)
  - Updating phpunit/phpunit (5.7.23 => 5.7.27)
  - Updating facebook/webdriver (1.4.1 => 1.5.0)
  - Installing codeception/stub (1.0.1)
  - Updating codeception/codeception (2.3.6 => 2.3.8)
  - Updating friendsofsymfony/oauth2-php (1.2.1 => 1.2.2)
  - Updating php-http/discovery (1.3.0 => 1.4.0)
  - Updating swiftmailer/swiftmailer (v5.4.8 => v5.4.9)
  - Updating sensiolabs/security-checker (v4.1.6 => v4.1.7)
  - Updating jms/serializer (1.9.1 => 1.11.0)
  - Updating lightsaml/lightsaml (1.3.1 => 1.3.3)


Pull #5718

Pequenas melhorias do Mautic 2.13.0

O Mautic 2.13.0 trás ainda pequenas mellhorias e correções:

  • Novo campo “Responder Para” disponível na ação Enviar Resultados de Formulário;
  • Correções na integração com o Pipedrive
  • Remoção das notificações de falhas em campanhas com contatos removidos
  • Importação de Contatos retorna 0 quando a importação é postergada
  • Usuários serão notificados sobre e-mails desativados em campanhas

Lançamento em Abril de 2018

O Mautic 2.13.0 está previsto para a primeira semana de Abril de 2018 e deve chegar em versão beta. A comunidade de desenvolvedores se mostra cada vez mais sólida e conectada com os passos definidos pelo core do Mautic ainda em 2017. A Ferramenta de Automação de Marketing que mais cresce no Brasil está cada vez mais forte!

Se você é cliente da powertic pode solicitar seu ambiente beta para testar os novos recursos do Mautic 😉

É fácil atualizar o Mautic no Powertic Cloud.

Deixe uma resposta

Esse site utiliza o Akismet para reduzir spam. Aprenda como seus dados de comentários são processados.

Pensando em atualizar o Mautic?

Acompanhe passo a passo os principais Guias para Manutenção do Mautic

Como Atualizar o Mautic 2+ através da Linha de Comando

Como Atualizar o Mautic na Linha de Comando

Com este novo procedimento ganhamos mais estabilidade e consistência durante a atualização das migrações do banco de dados, o script também limpa a pasta cache e corrige algumas permissões dos arquivos.

Leia Agora